よくあるご質問

ご契約前によくあるご質問をまとめています。
お問い合わせの前に、ぜひ一度ご覧下さい。

全て表示

トップ > よくあるご質問 > ご契約前によくあるご質問

ご契約前によくあるご質問

旧共用サーバ  >  CGI・PHP関連
CGIを設置するディレクトリはどこですか?
各種プログラムのパスやバージョンを教えてください。
設置できないCGIやその他制限はありますか?
自分で用意したCGIはインストールできますか?
SSIで使用できないコマンドはありますか?
sendmailは使えますか?
nkfは使えますか?
Perlモジュールのインストール状況を教えてください?
PerlのDB用のモジュールはインストールされていますか?
rubyは使えますか?
mod_perlは使えますか?
.htaccessは使えますか?
エラーログは見れますか?
CGIが動かない場合のサポートはありますか?
PHPのバージョンは?

No.78  CGIを設置するディレクトリはどこですか?
cgi-bin ディレクトリ、または拡張子が .cgi であればcgi-bin以外のディレクトリでも実行できます。

No.79  各種プログラムのパスやバージョンを教えてください。
perl /usr/bin/perl /usr/local/bin/perl バージョン: perl5.6.1 python /usr/bin/python バージョン: 1.5 ruby /usr/bin/ruby バージョン: 1.6.7 sendmail /usr/sbin/sendmail date /bin/date nkf /usr/bin/nkf uuencode /usr/bin/uuencode uudecode /usr/bin/uudecode

No.80  設置できないCGIやその他制限はありますか?
共用サーバのため、チャット等の負荷の高いプログラムのご利用は他のお客様に影響のあるためご遠慮いただいております。状況によっては緊急停止させていただく場合があります。

No.81  自分で用意したCGIはインストールできますか?
はい、インストールできます。

No.82  SSIで使用できないコマンドはありますか?
特にありません。

No.83  sendmailは使えますか?
はい、使えます。

No.84  nkfは使えますか?
はい、使えます。

No.85  Perlモジュールのインストール状況を教えてください?
必要なモジュールがあれば個別にお問合せください。

No.86  PerlのDB用のモジュールはインストールされていますか?
DBI, DBD::Pg, DBD::mysql, Pg の各モジュールがご利用いただけます。

No.87  rubyは使えますか?
はい、使えます。

No.88  mod_perlは使えますか?
使えません。

No.89  .htaccessは使えますか?
使えます。

No.90  エラーログは見れますか?
見れます。

No.91  CGIが動かない場合のサポートはありますか?
基本的にお客様がアップロードしたコンテンツについてはサポートの対象外となっておりますが、サーバの不具合が疑われる場合はお調べすることもあります。

No.92  PHPのバージョンは?
4.4.2 + patch です。